Home Sociedad Cientos de modelos de impresoras HP, vulnerables a la ejecución remota de...

Cientos de modelos de impresoras HP, vulnerables a la ejecución remota de código

HP ha publicado avisos de seguridad sobre tres vulnerabilidades de gravedad crítica que afectan a cientos de sus modelos de impresoras LaserJet Pro, Pagewide Pro, OfficeJet, Enterprise, Gran Formato y DeskJet.

El primer boletín de seguridad advierte sobre un fallo de desbordamiento de búfer que podría conducir a la ejecución remota de código en el equipo afectado. Registrado como CVE-2022-3942, el problema de seguridad fue reportado por el equipo de la Iniciativa Día Cero de Trend Micro.

Aunque tiene una puntuación de gravedad de 8,4 (alta), calculada con el Sistema de Puntuación de Vulnerabilidad Común (CVSS), HP considera que la gravedad del fallo es crítica.

“Ciertos productos de impresión de HP y productos de envío digital pueden ser vulnerables a la potencial ejecución remota de código y al desbordamiento del búfer con el uso de Link-Local Multicast Name Resolution o LLMNR”, reza el aviso.

HP ha publicado actualizaciones de seguridad del firmware para la mayoría de los productos afectados. Para los modelos sin parche, la compañía proporciona instrucciones de mitigación que giran principalmente en torno a la desactivación de LLMNR (Link-Local Multicast Name Resolution) en la configuración de la red.

Las tres vulnerabilidades se rastrean como CVE-2022-24291 (puntuación de gravedad alta: 7,5), CVE-2022-24292 (puntuación de gravedad crítica: 9,8) y CVE-2022-24293 (puntuación de gravedad crítica: 9,8). El mérito de informar sobre ellos también corresponde al equipo de la Iniciativa Día Cero.

También en este caso, la recomendación oficial es actualizar el firmware de la impresora a las versiones designadas, pero esto no está disponible para todos los modelos afectados.

No hay consejos de mitigación para remediar el problema para uno de los modelos LaserJet Pro enumerados, pero se ha marcado como pendiente, por lo que las actualizaciones de seguridad para ese deberían estar disponibles pronto.

Los administradores de todos los demás modelos pueden visitar el portal oficial de descarga de software y controladores de HP, navegar para seleccionar su modelo de dispositivo e instalar la última versión de firmware disponible.

Aunque no se han publicado muchos detalles sobre estas vulnerabilidades, las repercusiones de la ejecución remota de código y la divulgación de información son, en general, de gran alcance y potencialmente nefastas.

Con información de: Genbeta.